Routing Protocol Cisco

Routing Protocol
Static Routing
ip route <Destination prefix><Gateway> name <description>
Example
ip route 0.0.0.0 0.0.0.0 10.100.100.1 name ALL-BRANCH
ip route 192.168.1.0 255.255.255.0 10.100.100.1 name UIH-BRANCH
Verify
show ip route static
show ip route
RIP Routing
router rip
 version 2
 network <IP WAN prefix>
 network <IP LAN prefix>
 no auto-summary
Example
router rip
 version 2
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary
Verify
show ip route rip
show ip rip database
show ip route 
OSPF Routing
interface ATM0.100 point-to-point
 mtu 1500
 ip ospf network broadcast
!
router ospf <Process ID>
 router-id <IP WAN CE>
 log-adjacency-changes
 network <IP WAN prefix> area <Area>
 network <IP LAN prefix> area <Area>
Example
!
interface ATM0.100 point-to-point
 description ""Connect to WAN""
 mtu 1500
 ip address 10.100.100.2 255.255.255.252
 ip ospf network broadcast
 atm route-bridged ip
 pvc 0/33 
  encapsulation aal5snap
!
router ospf 100
 router-id 10.100.100.2
 log-adjacency-changes
 network 10.100.100.0 0.0.0.3 area 0
 network 192.168.1.0 0 0.0.0.255 area 0
Verify
show ip ospf neighbor
show ip route ospf
show ip route
BGP Routing
router bgp <AS# number>
 bgp log-neighbor-changes
 network <IP WAN prefix> mask <Subnet mask>
 network <IP LAN prefix> mask <Subnet mask>
 neighbor <IP WAN PE> remote-as <AS# number>
Example
router bgp 64501
 bgp log-neighbor-changes
 network 10.100.100.0 mask 255.255.255.252
 network 192.168.1.0 mask 255.255.255.0
 neighbor 10.100.100.1 remote-as 23892
Verify
show ip bgp neighbors
show ip route bgp
show ip route